Published Updates are not Showing in 'All Software Updates'

Published Updates are not Showing in 'All Software Updates'

Symptom

  1. Updates published using Lenovo Patch are not showing up in All Software Updates within the Configuration Manager console.
    OR
  2. When you are about to publish updates via Lenovo Patch, you see a message, Some of the selected updates may not synchronize.

    Publish Products Not Synched

    Click for details will show a list of updates you are attempting to publish that 'may not synchronize with the current Software Update Point configuration.'

    Publish Products Not Synched Information

Cause

  1. You have not performed a synchronization with the WSUS server.
  2. In the Lenovo Patch plugin, you will need to manage the product subscriptions. In Configuration Manager, you need to update your Software Update Point to ensure you're syncing the package classififcations.

Solutions

There are two possible solutions.

  1. You need to ensure you've successfully performed synchronization with the WSUS server.

    You may just need to perform the sync, or there may be a problem during the synchronization process that is causing the failure.

    Refer to the wsyncmgr.log from
    C:\Program Files\Microsoft Configuration Manager\Logs.
  2. In the Configuration Manager console, the Software Update Point will need to be updated to ensure WSUS and Configuration Manager are syncing the Updates classification and the appropriate products are enabled correctly.

    To check the Update Classification setting:
    1. In the Configuration Manager console, navigate to the Administration workspace.
    2. Navigate to Site Configuration > Sites.
    3. Right-click on the primary site > Configure Site Components > Software Update Point.
    4. Click on the Classifications tab.
    5. Ensure the Updates classification has a check mark in the box.

      Classification

    6. Click the OK button to accept the settings and close the dialog.

    To check the Product settings:
    1. In the Configuration Manager console, navigate to the Software Library workspace.
    2. Navigate to Software Updates > Lenovo Patch > Updates.
    3. Click on the Manage Products button on the ribbon bar.
    4. In the Manage Products dialog, expand vendors and ensure there is a check mark next to any newly added products.

      Manage Products Subscribe

    5. Click the Subscribe button.
    6. After the Subscribe action completes, click the Synchronize button.
    7. Click the Close button on the Manage Products dialog to close the window.

Additional Information

To help mitigate these issues, enable the 'Automatically subscribe to categories after a publish synchronization' setting.

  1. In the Configuration Manager console, navigate to the Software Library workspace.
  2. Navigate to Software Updates > Lenovo Patch > Updates.
  3. Click on Settings in the ribbon bar.
  4. In the Lenovo Patch Settings dialog, select the WSUS Server tab.
  5. Scroll to the bottom of the tab to the 'Automatic category subscription' section.
  6. Check the box by the Automatically subscribe to categories after a publish synchronization setting.
  7. Click the OK button.
    • Related Articles

    • Lenovo Updates Catalog Agent – Deploy Me First

      Purpose: Provide general information regarding the functionality, versions, location in the catalog, and installation of the Lenovo Updates Catalog Agent. Functionality Why is the Lenovo Updates Catalog Agent Needed? When installing driver updates, ...
    • Timestamp Updates

      Purpose This article is to help provide guidance on using the timestamp server options when publishing updates using the Lenovo Patch plugin. Description Adding a timestamp to an update during the publishing process will identify when the update was ...
    • Expiring Third-Party Updates and Running the WSUS Server Cleanup

      Purpose This document is meant to provide information on how to expire third party updates via the Lenovo Patch plugin and how to run the WSUS Server Cleanup to remove expired updates and free up space on the WSUS server. Description When using the ...
    • FileZilla Patching Updates

      Symptom Updates for FileZilla are not downloaded by Lenovo Patch when selected to be published. Solution Customers who have tried to patch FileZilla may have noticed that updates for FileZilla are not being downloaded by Lenovo Patch. Changes from ...
    • Error: 87D00669 - Not able to get software updates content locations at this time

      Symptom Software Center or the Deployment has an error code: 0x87D00669 Error code resolves to message: Not able to get software updates content locations at this time Cause The software update content is not on a distribution point that the endpoint ...