Manifest Synchronization Error: WsusCatalog2.zip Failed Integrity Validation
Symptom
In either the Lenovo Patch.log, the AutoPublish.log or both, the following error is present: Manifest synchronization error. Code=Failed, message=File 'C:\Users\USERNAME\Lenovo\Lenovo Patch\WsusCatalog2.zip' failed integrity validation: https://content.ivanti.com/data/{VERSION}/WsusCatalog2.zip
Cause
Either the previous code-signing certificate used to sign the catalog data is now expired
OR
The new code-signing certificate issued to the new catalog data is not trusted.
Solution
- Download the "DigiCert Trusted Root G4" certificate from the DigiCert Trusted Root Authority Certificates page.
- Using CERTLM.MSC, import the DigiCertTrusted RootG4.crt file into the Trusted Root Certification Authorities Certificate store.
- If present, delete the 'C:\Users\USERNAME\Lenovo\Lenovo Patch\WsusCatalog2.zip' file.
- Close and reopen the console, navigate to the Lenovo Patch plugin, and verify using the log file that the WsusCatalog2.zip file is successfully downloaded and verified.
- In addition to the "DigiCert Trusted Root G4" certificate, the "DigiCert Trusted G4 Code Signing RSA4096 SHA384 2021 CA1" certificate may be required as an intermediate certificate to establish the certificate chain.
- Download the "DigiCert Trusted G4 Code Signing RSA4096 SHA384 2021 CA1" certificate from the DigiCert Trusted Root Authority Certificates page.
- Using CERTLM.MSC, import the DigiCertTrustedG4CodeSigningRSA4096SHA3842021CA1.crt file into the Intermediate Certification Authorities Certificate store.
- If present, delete the 'C:\Users\USERNAME\Lenovo\Lenovo Patch\WsusCatalog2.zip' file.
- Close and reopen the console, navigate to the Lenovo Patch plugin, and verify using the log file that the WsusCatalog2.zip file is successfully downloaded and verified.