License Refresh: The underlying connection was closed: Could not establish trust relationship for the SSL TLS secure channel.

License Refresh: The underlying connection was closed: Could not establish trust relationship for the SSL TLS secure channel.

Problem

During a publication task, the AutoPublish.log records a notification: "License Refresh: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel."

Cause

The console device does not trust one of the certificates in the SSL certificate chain securing the website.

Resolution

  1. Allow the URLs for Lenovo Patch functionality from the URL Exception List and Certificate Verification Sites Knowledge Base Article.
  2. Allow the URLs for the Certificate Verification Sites from the URL Exception List and Certificate Verification Sites Knowledge Base Article.
  3. On the device with the License Refresh error, do the following:
    • Open a web browser.
    • Navigate to https://stlicense.ivanti.com
    • In, on, or near the address bar, find the icon providing further information about the security and certificate on the site.
    • Review the certificate and determine what part of the chain is not trusted.
    • If the untrusted certificate is the root certificate, follow Microsoft documentation to update the root certificates on the device.
    • Related Articles

    • Verify Requirements with the Configuration Checker

      Purpose The Configuration Checker is used to determine if your Configuration Manager environment meets all the requirements for using Lenovo Patch. Description To access the Lenovo Patch Configuration Checker, do the following: In the Configuration ...
    • Managing Licenses within TSFA

      ThinkShield Firmware Assurance (TSFA) operates on a device-based SaaS model. Licenses for TSFA can be purchased through standard Lenovo channels and applied to UDS / TSFA. Within the TSFA portal, administrators can view the organization's purchased ...
    • End-User License Agreement

      Description Provide access to the End-User License Agreement found in the Lenovo Patch installer. Related Article https://support.lenovo.com/solutions/HT514029
    • Setting Up Data Defense

      After completing the installation and activating your account, you can proceed to set up Data Defense. Log in to your account and follow the on-screen wizard, which will guide you through: Setting up a Secure Drive (if available). Configuring folder ...
    • Error: 'Invalid Key: contact support' when attempting to validate license key

      Symptom When attempting to validate the activation key in Lenovo Patch settings, an error message stating "Invalid Key: contact support" is returned. The license key cannot be validated to activate Lenovo Patch. Solution Check the following list to ...