Failed to retrieve updates from the specified WSUS server: The operation has timed out

Failed to retrieve updates from the specified WSUS server: The operation has timed out

Symptom

When opening the Lenovo Patch plugin, the catalog fails to load and shows a "Loading" prompt, which eventually times out.

Lenovo Patch Loading Placeholder

In the Lenovo Patch.log file, the following error message is captured:

Failed to retrieve updates from the specified WSUS server: The operation has timed out
WebException

The exception is then followed by a stack trace.

Cause

An issue in the environment is preventing WSUS from communicating with the Lenovo Patch plugin properly and is timing out.

Solution

Please ensure there is a backup or snapshot of the WSUS server and / or database prior to troubleshooting any WSUS issues.

Use the Configuration Checker to verify all settings and permissions are configured correctly.

Verify WSUS Administrators have the correct permissions in DCOM Config. Full instructions can be found in the resolution section of the Error Accessing the WSUS Signing Certificate Knowledge Base Article.

Use the WSUS Cleanup Tool to clean up updates that are no longer needed. Refer to the WSUS Cleanup process defined in the Expiring Third-Party Updates and Running the WSUS Server Cleanup Knowledge Base Article.

Once these tasks are complete, restart the server and attempt to access Lenovo Patch again. If the above instructions do not work, use the below linked document from Microsoft to run maintenance tasks on the WSUS and Software Update Points in the environment.
https://docs.microsoft.com/troubleshoot/mem/configmgr/wsus-maintenance-guide