Error: A specified logon session does not exist. It may already have been terminated

Error: A specified logon session does not exist. It may already have been terminated

Symptom

The error, "A specified logon session does not exist. It may already have been terminated" is encountered as part of a Stack Trace dump found in the Lenovo Patch.log or the DataMigrationTool.log beginning with version 2.5.586.0 orlater.

Cause

The user account encountering the error is a member of the Protected Users Active Directory security group.

This is caused by the extra protections that Windows applies to accounts that are a member of this security group. Highlighted in the Microsoft documentation for the Protected Users security group is the following warning:

  • Accounts for services and computers should never be members of the Protected Users group. This group provides incomplete protection anyway because the password or certificate is always available on the host. Authentication will fail with the error "the user name or password is incorrect" for any service or computer that is added to the Protected Users group."

Solution

To utilize the Lenovo Patch plugin, the account will need to be removed from the Protected Users Active Directory security group to allow successful authentication.

    • Related Articles

    • Failed to retrieve updates from the specified WSUS server: The operation has timed out

      Symptom When opening the Lenovo Patch plugin, the catalog fails to load and shows a "Loading" prompt, which eventually times out. In the Lenovo Patch.log file, the following error message is captured: Failed to retrieve updates from the specified ...
    • Error: 0x800B0109 - Updates not installing

      Symptom After publishing updates from the Lenovo Patch plugin and deploying the updates using Configuration Manager, the client computer fails to install updates and receives an error on installation: 0x800B0109(-2146762487). The error is found in ...
    • Error When Scheduling Task as Another User

      Symptom When attempting to schedule any task using the Automation Scheduler interface as 'Different User' and clicking the 'Add task' or 'Edit task' button, an error message dialog appears on screen. Cause The computer or server, where the console is ...
    • Error Accessing the WSUS Signing Certificate

      Symptom The Configuration Checker returns a failure on the check 'A WSUS Signing Certificate is in place and can be accessed by the user' with a detail of 'Error accessing the WSUS signing certificate. The certificate does not exist or your account ...
    • Error: 'Failed to sign package; error was: 2148081670' when Publishing Updates

      Symptom When using the Configuration Checker to validate the settings, an error is returned: OR When publishing updates, the AutoPublish.log will show: 'Failed to sign package; error was: 2148081670' Solution The error code resolves to 'No provider ...